欢迎光临
我们一直在努力

易语言内存优化

.版本 2

.DLL命令 SetProcessWorkingSetSize, 整数型, "kernel32", "SetProcessWorkingSetSize", , ;    设置操作系统实际划分给进程使用的内存容量  非零表示成功,零表示失败。会设置GetLastError
    .参数 hProcess, 整数型, , 指定一个进程的句柄
    .参数 dwMinimumWorkingSetSize, 整数型, , 用于装载最小进程容量的一个变量
    .参数 dwMaximumWorkingSetSize, 整数型, , 用于装载最大进程容量的一个变量适用平台Windows NT;

.DLL命令 取当前进程伪句柄_, 整数型, "kernel32.dll", "GetCurrentProcess", , GetCurrentProcess
.版本 2

.子程序 _时钟1_周期事件

SetProcessWorkingSetSize (取当前进程伪句柄_ (), 50000, 100000)

易语言物理内存优化源码例程程序调用API函数实现物理内存优化。

赞(0)
未经允许不得转载:阿强爱分享 » 易语言内存优化

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址