网址缩短服务调用模块开源,含API

网站API:http://www.7x0.cn/api.php 

POST请求:{"success":"focus","url":"#网址#"}  



常量表 json内容:{"success":"focus","url":"#网址#"}

.版本 2

.支持库 spec

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

调试输出 (生成网址 (“http://www.yudilu.com”))
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 _临时子程序

' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

.子程序 生成网址, 文本型, 公开, 提交参数url
.参数 url, 文本型, , 要缩短的URL地址
.局部变量 返回数据, 文本型
.局部变量 json, 文本型

json = 子文本替换 (#json, “#网址#”, url, , , 真)
返回数据 = 网页_访问S (“http://www.7x0.cn/api.php”, 1, json)
返回数据 = JSON (返回数据, “content.url”)
返回 (返回数据)

.子程序 JSON, 文本型
.参数 JSON数据, 文本型, , JSON数据
.参数 取数据, 文本型, , JSON路径
.局部变量 JSON, 类_json

JSON.解析 (JSON数据)
返回 (JSON.取通用属性 (取数据))

未分类
阿强爱分享
  • 本文由 发表于 2018年7月1日21:16:09
  • 转载请务必保留本文链接:https://iooqp.cn/53.html
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: